Welcome, Guest
Username: Password: Remember me

TOPIC: Can't Edit Profile

Can't Edit Profile 5 years 3 months ago #6558

  • Shane Thorpe
  • Shane Thorpe's Avatar
  • Offline
  • Expert Boarder
  • Posts: 113
  • Thank you received: 11
I can’t edit anything on the forum. Trying to update my profile which was changed a while back. Is no biggy as I can post and edit when logged in but need to sort the profile.

You can see at the top I am logged in but can't edit anything apart from Save and Cancel. – any ideas?

Also just tried to attach images to this post to clarify the issue and that doesn't work either.
Moderator for MJUG forum.
The topic has been locked.

Can't Edit Profile 5 years 3 months ago #6560

  • MaxTech
  • MaxTech's Avatar
  • Offline
  • Gold Boarder
  • Posts: 222
  • Thank you received: 23
Hi Shane,
The code is there but not visible, so you can edit your info by going to the profile edit page and then brining up the code in firefox and edit the CSS to visible until the elements you want to change can be seen - than you can enter the info and submit . . . . it works, cause I updated mine that way ;)

Not sure if this was intentional or if the template is broken / CSS needs fixing. There's also some other stuff on the site template/customisations that needs fixing up, but I'm assuming that will just happen at some time.
(PS: this template as default often has the same issues, so it's not just this site, it's the default install of this template).

Hope that helps Shane (& Dex)
Founder & CEO @ molehill.com.au & successeng.in
Partner @ joostrap.com - Joomla! Website Templates & Responsive Web Design
The topic has been locked.

Can't Edit Profile 5 years 2 months ago #6569

  • buipy001
  • buipy001's Avatar
  • Offline
  • Moderator
  • Peter Bui
  • Posts: 111
  • Thank you received: 25
Hilarious.

Will update my profile
Peter Bui

The only limitation is your imagination
pbwebdev.com

Twitter: twitter.com/astroboysoup
Facebook: facebook.com/pbwebdev
The topic has been locked.

Can't Edit Profile 5 years 2 months ago #6575

  • sozzled
  • sozzled's Avatar
  • Offline
  • Moderator
  • I'm just a user, mate!
  • Posts: 119
  • Thank you received: 22
It's more than just a case of the CSS {display: none} attribute being set on the profile tabs. The problem is that there is some Javascript library conflict in the template itself that is clobbering Joomla's Mootools. While I see that the template is (interestingly) called a "Bootstrap Responsive" (and we understand that Joomla's Bootstrap will be driven around a jQuery Javascript library core, it is not always good to be loading jQuery ("no-conflict" mode notwithstanding) after loading Mootools when many of the leading J! 2.5 developers are using "mainstream" J! 2.5 practices that are reliant on Mootools operating correctly.

The Javascript library conflict prevents the tab controls (User Account, Profile Information,Forum Settings) from switching between the different views. That's the real problem here.
Shane Thorpe wrote:
I just tried to attach images to this post to clarify the issue and that doesn't work either.
I have fielded hundreds of similar questions. Conflict with Joomla's Mootools is, again, the cause.

This begs the question Which came first? The template or the forum?

The simple fact of the matter is that we are unable to edit our profiles. While it's all well and good for those "in the know" to be able to update their profiles (or able to insert their Gravatar avatar) is not good forum practice. Speaking of avatar images, how the hell do you update those things? :laugh:

I have offered my help to assist those who run this forum on many occasions. Apart from a handful of "G'day, how are you" messages, no-one has really taken up my offer to work through the issues. I only wish for the success of Joomla in Australia and to be able to make a small contribution to that success.
Read my blog and
Last Edit: 5 years 2 months ago by sozzled.
The topic has been locked.

Can't Edit Profile 5 years 2 months ago #6580

  • MaxTech
  • MaxTech's Avatar
  • Offline
  • Gold Boarder
  • Posts: 222
  • Thank you received: 23
Yeah . . . a lot of "newer" templates, plugins, etc have an option to disable mootools which can cause issues. If the tabs ar driven by mootools then that may be the issue.

Additionally, there are good ways and bad ways to manage JS (and jQuery) on a site and also as they are handled by templates - I don't think it is a template issue as such here (with Joostrap), but mootools may be disabled.

Could always just change the ID/classes of the tabs in the Kunena template (or custom overrides) to bootstrap enabled tabs? That'd probably get correct visibility and styling of the tabs & be J3 compatible.

PS: I have seen your offers for help - I think I would have taken you up on that . . . but I'm only a user here mate, so I have no control over that, but I would like to say thanks for being so generous - you are an asset to the open source Joomla community, especially on the Kunena forums . . or is that just your second home ;)
Founder & CEO @ molehill.com.au & successeng.in
Partner @ joostrap.com - Joomla! Website Templates & Responsive Web Design
Last Edit: 5 years 2 months ago by MaxTech.
The topic has been locked.

Can't Edit Profile 5 years 2 months ago #6585

  • sozzled
  • sozzled's Avatar
  • Offline
  • Moderator
  • I'm just a user, mate!
  • Posts: 119
  • Thank you received: 22
MaxTech wrote:
Yeah . . . a lot of "newer" templates, plugins, etc have an option to disable mootools which can cause issues. If the tabs ar driven by mootools then that may be the issue.
Kunena follows the recommendations of the Joomla development community (see MooTools and Kunena 1.6) and, for that reason, the Kunena team decided not to continue with jQuery or to try to do anything "clever" to rewrite the whole Javascipt library "thing". Now that it appears that the Joomla community may, indeed, "embrace" jQuery for the Bootstrap framework this is going to set the cat among the pigeons in the Joomla extension development world.

Basically you are right. As long as a website has unfettered access to Joomla's Mootools (which are a core part of J! 2.5) everything should be hunky-dory. In my article My Joomla site template makes a mess of Kunena I made the point that people need to carefully consider the kinds of templates that they install. It all depends on whether the template is designed with Mootools in mind or something else. It also means that people who install Kunena should ask the people they're buying their site template from one important question: "Does your template work with Kunena?" Some templates do and some templates don't. With several million Joomla templates floating around the 'net, it's an impossible task for the Kunena development team to test anything more than the stock-standard Joomla templates.

We know that template development will change the course of the Joomlaverse as we know it with J! 3.0 and we have to keep abreast of those developments. That's something that all Joomla extension developers have to factor into their priorities.

I have dealt with many of these kinds of issues when they put before me on the Kunena forum and, believe me, "you win some, you lose some".
MaxTech wrote:
I have seen your offers for help - I think I would have taken you up on that . . . but I'm only a user here mate, so I have no control over that.
My offers of help have not been accepted by those who could make a difference; c'est la vie. B)
MaxTech wrote:
you are an asset to the open source Joomla community, especially on the Kunena forums . . or is that just your second home ;)
Thank you. Yes, you could say I spend a little bit of my time at www.kunena.org and traipsing around the Joomla forums too.:D
Read my blog and
Last Edit: 5 years 2 months ago by sozzled.
The topic has been locked.

Can't Edit Profile 5 years 3 weeks ago #6673

It still doesn't work guys. i.e. www.joomla.org.au/forum/profile2/edit

We had the same problem in Joomla 1.5

Just turn on the Mootools Upgrade plugin and it will work.
Regards,
Alastair Coleman
nothingbutweb.com.au | visualimpactwebdesign.com.au

Phone: 1300 847 908
Direct: 03 8613 8426
Office: Level 3, 131 Queen Street, Melbourne VIC 3000
The topic has been locked.

Can't Edit Profile 4 years 6 months ago #6955

  • Lenfitz
  • Lenfitz's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 8
  • Thank you received: 4
Is this ever going to be fixed?

Because it's not a good look from Joomla's point of view. Buggy is not kewl :(
Member of the Australian Joomla Translation Team
The topic has been locked.
Time to create page: 0.055 seconds
Powered by Kunena Forum