Welcome, Guest
Username: Password: Remember me
Got a Joomla problem? Post as much detail about it as you can here to see if you can get a solution.

Help others in the community - post your Joomla tips and how-tos here.

TOPIC: What do I need to do to keep VirtueMart 1.1.9 PayPal payments working?

What do I need to do to keep VirtueMart 1.1.9 PayPal payments working? 11 months 3 weeks ago #7810

  • ozneilau
  • ozneilau's Avatar
  • Offline
  • Senior Boarder
  • Posts: 78
  • Thank you received: 9
Posting on the VirtueMart forums has been disabled for unsupported versions of VirtueMart so I am posting this here in case anyone else here is supporting an older version of VirtueMart and can help.

I have a Joomla 1.5 / VirtueMart 1.1.9 client that has received an email from PayPal about an upcoming IPN Verification Postback to HTTPS change that PayPal believes will affect their site:

Merchants and partners use Instant Payment Notification (IPN) to receive notifications of events related to PayPal transactions. The IPN message service requires that you acknowledge receipt of these messages and validate them. This process includes posting the messages back to PayPal for verification. In the past, PayPal has allowed the use of HTTP for these postbacks. For increased security going forward, only HTTPS will be allowed for postbacks to PayPal. At this time, there is no requirement for HTTPS on the outbound IPN call from PayPal to the merchant’s IPN listener.

Other than upgrading to the latest version, what, if anything, needs to be done so PayPal payments will still work under VirtueMart 1.1.9?
Webilicious Web Design and Development
webilicious.com.au
The administrator has disabled public write access.

What do I need to do to keep VirtueMart 1.1.9 PayPal payments working? 11 months 3 weeks ago #7813

  • codekadiya
  • codekadiya's Avatar
  • Offline
  • Senior Boarder
  • Posts: 40
  • Thank you received: 2
Im not a paypal expert but what method of paypal and virtumart you are using.

Is it Paypal Standard or Express checkout?
The administrator has disabled public write access.
The following user(s) said Thank You: ozneilau

What do I need to do to keep VirtueMart 1.1.9 PayPal payments working? 11 months 3 days ago #7867

  • ozneilau
  • ozneilau's Avatar
  • Offline
  • Senior Boarder
  • Posts: 78
  • Thank you received: 9
It's the standard PayPal payment method.
Webilicious Web Design and Development
webilicious.com.au
The administrator has disabled public write access.

What do I need to do to keep VirtueMart 1.1.9 PayPal payments working? 11 months 3 days ago #7870

  • codekadiya
  • codekadiya's Avatar
  • Offline
  • Senior Boarder
  • Posts: 40
  • Thank you received: 2
Is the website has SSL installed?
Last Edit: 11 months 3 days ago by codekadiya.
The administrator has disabled public write access.

What do I need to do to keep VirtueMart 1.1.9 PayPal payments working? 11 months 2 days ago #7873

  • sozzled
  • sozzled's Avatar
  • Offline
  • Moderator
  • I'm just a user, mate!
  • Posts: 96
  • Thank you received: 16
ozneilau wrote:
I have a Joomla 1.5 ...
J! 1.5 has been unsupported for over 4 years—April 2012 in fact—and it is known to be vulnerable to attack. C'est la vie.
Read my blog and
The administrator has disabled public write access.
The following user(s) said Thank You: ozneilau

What do I need to do to keep VirtueMart 1.1.9 PayPal payments working? 10 months 3 weeks ago #7875

  • ozneilau
  • ozneilau's Avatar
  • Offline
  • Senior Boarder
  • Posts: 78
  • Thank you received: 9
codekadiya wrote:
Is the website has SSL installed?

No.
Webilicious Web Design and Development
webilicious.com.au
Last Edit: 10 months 3 weeks ago by ozneilau. Reason: add quoted text to provide more context ;)
The administrator has disabled public write access.

What do I need to do to keep VirtueMart 1.1.9 PayPal payments working? 10 months 3 weeks ago #7876

  • ozneilau
  • ozneilau's Avatar
  • Offline
  • Senior Boarder
  • Posts: 78
  • Thank you received: 9
sozzled wrote:
ozneilau wrote:
I have a Joomla 1.5 ...
J! 1.5 has been unsupported for over 4 years—April 2012 in fact—and it is known to be vulnerable to attack. C'est la vie.

The client is aware of this and hopefully this latest concern may lead to an upgrade!

I responded to a question on Stack Overflow the other day stackoverflow.com/a/38012407/1983389 from a Joomla 1.0.12 website owner who I imagine must be fairly smug after being told he needs to upgrade for the past 7 years or so. :)
Webilicious Web Design and Development
webilicious.com.au
Last Edit: 10 months 3 weeks ago by ozneilau. Reason: Fix link
The administrator has disabled public write access.
Time to create page: 0.052 seconds
Powered by Kunena Forum