Welcome, Guest
Username: Password: Remember me
Got a Joomla problem? Post as much detail about it as you can here to see if you can get a solution.

Help others in the community - post your Joomla tips and how-tos here.

TOPIC: 504 Gateway timeouts

504 Gateway timeouts 1 month 1 day ago #8374

  • Cameron S
  • Cameron S's Avatar
  • Offline
  • Junior Boarder
  • Posts: 38
  • Thank you received: 6
Hi guys,

I am having an issue with a particular site where in attempting to update either Akeeba Backup or JCE pro I am getting a Gateway timeout error.

Tried a bunch of stuff and the update files have worked on other sites fine. Siteground has drawn a bit of a blank.

Anyone run into this kind of an issue?

Cheers

Cameron
The administrator has disabled public write access.

504 Gateway timeouts 1 month 1 day ago #8375

  • manuman
  • manuman's Avatar
  • Offline
  • Moderator
  • Posts: 75
  • Thank you received: 18
I'm not up on Siteground's internals, but if they use cPanel or Plesk see if you can get the logs. From that we would hopefully be able to see whats going on.
Co-Founder of Joomla!
CTO/Web Architect - Elastik Space elastik.space / Elastik Digital elastik.digital
The administrator has disabled public write access.

504 Gateway timeouts 1 month 1 day ago #8376

  • Cameron S
  • Cameron S's Avatar
  • Offline
  • Junior Boarder
  • Posts: 38
  • Thank you received: 6
Hi manuman,

Nothing in the error logs via the cpanel. Is there another place I should be looking?

Cheers
The administrator has disabled public write access.

504 Gateway timeouts 1 month 1 day ago #8377

  • manuman
  • manuman's Avatar
  • Offline
  • Moderator
  • Posts: 75
  • Thank you received: 18
I'm assuming you are trying to update via the updater.

If so, try downloading the packages to your desktop then uploading via the installer. Should have the same end result.
Co-Founder of Joomla!
CTO/Web Architect - Elastik Space elastik.space / Elastik Digital elastik.digital
The administrator has disabled public write access.

504 Gateway timeouts 1 month 1 day ago #8378

  • Cameron S
  • Cameron S's Avatar
  • Offline
  • Junior Boarder
  • Posts: 38
  • Thank you received: 6
No luck. The zip file uploaded then a long pause followed by this;

"Gateway Timeout

The gateway did not receive a timely response from the upstream server or application."

The client has said he had issues with updating Akeeba but it has now extended to JCE.

Not sure where to head next.

Edit: Reading some forums indicated it may have been caching in php 7 so I returned the version back to an earlier one but still no luck.
Last Edit: 1 month 1 day ago by Cameron S.
The administrator has disabled public write access.

504 Gateway timeouts 1 month 1 day ago #8379

  • sozzled
  • sozzled's Avatar
  • Offline
  • Moderator
  • I'm just a user, mate!
  • Posts: 116
  • Thank you received: 20
I'm not sure if this might help (because I can't remember the last time I had a [HTTP 504] Gateway Timeout error), but I suggest you look at php.net/manual/en/features.file-upload.common-pitfalls.php
max_input_time sets the maximum time, in seconds, the script is allowed to receive input; this includes file uploads. For large or multiple files, or users on slower connections, the default of 60 seconds may be exceeded.

Does that help? :unsure:
Read my blog and
The administrator has disabled public write access.

504 Gateway timeouts 1 month 1 day ago #8380

  • Cameron S
  • Cameron S's Avatar
  • Offline
  • Junior Boarder
  • Posts: 38
  • Thank you received: 6
Hi sozzled,

I have increased the memory limit which was set at 768. Not sure why.

"The following changes were stored to /home/xxx/public_html/php.ini :

memory_limit = 128M
max_execution_time = 120
opcache.enable = Off
zend_extension=/usr/local/php56/lib/php/extensions/ioncube.so
zend_extension=/usr/local/php56/lib/php/extensions/ZendOptimizer.so "

Still getting the timeout error.

Curiouser and curiouser.
The administrator has disabled public write access.

504 Gateway timeouts 1 month 22 hours ago #8381

  • sozzled
  • sozzled's Avatar
  • Offline
  • Moderator
  • I'm just a user, mate!
  • Posts: 116
  • Thank you received: 20
I searched Google for similar questions asked about Joomla and Gateway Timeout problems. I found a few references to older versions of Joomla and various issues that caused these errors; I don't know if the version of Joomla you are using is related to these kinds of issues or not.

One possible factor (in addition to the max_input_time PHP setting that I mentioned before) may be whether you have any FTP layer settings enabled in the Global Configuration settings (but, I somehow doubt that). I still believe, even though I have not encountered this problem myself in several years, that the problem relates to the php.ini settings in effect on the server.

Note: some php.ini settings cannot be modified by the site owner (or if they can be changed, they have no effect), particularly on shared webhosting environmnents.
Read my blog and
Last Edit: 1 month 22 hours ago by sozzled.
The administrator has disabled public write access.

504 Gateway timeouts 1 month 9 hours ago #8382

  • Cameron S
  • Cameron S's Avatar
  • Offline
  • Junior Boarder
  • Posts: 38
  • Thank you received: 6
Hi sozzled,

Yes my plumbing of the forums leads me to believe it is something php related now I'm not as sure.

The site is on a Geek level hosting platform from Siteground apparently boasting;

Simultaneous Server Processes: 30
Simultaneous Connections from Single IP: 20
CPU Seconds / Program and Script Executions: 4000/hour, 40000/day, 800000/month
Average Process Execution Time per Day: 4 seconds
Shared Service CPU Usage: No more than 20% for a period longer than 10 seconds
Server Memory per Process: 768 MB
Inodes: 450,000
Minimum Cron Job Interval: 30mins


The issue first appeared when trying to update Admin Tools. This is the exchange with Tech Support at Siteground;

Hello! I am having trouble with timeouts interrupting an Akeeba Admin Tools update which has caused issues with our site. Checking his forums it seems I might have to empty the op-cache. The error message I am geting now is FOF 3.0 is not installed. When i tried to update Admin tools I got a timeout error and then a subsequent error when attempting to use it.

This was bumped to the next level Tech Support who advised;

I have been able to replicate this, clearing the opcache made no difference. I tried disabling opcache for your site temporarily, this made no no change either. Please confirm if it is ok for us to remove the plugin and install it again from the original source. Looking forward to your update.

Best regards, Technical Support Team


After giving permission I received this message;

I am escalating your ticket to our Senior Technical Support team to review this closer for you. You will receive an update as soon as more information is available.

Best regards, Technical Support Team


The next message was;

We tried to resolve the issue but to no avail, we cleared your site's OPCache and tried using a different PHP version but to no avail. The FOF package is actually installed and working so I would advise you seek assistance from Akeeba's Help Desk. Of course, if there is anything we could do from our end, we would be more than happy to help.

Best Regards, Senior Technical Support


Since then the JCE update has virtually the same issues.

Well it looks like it's back to Siteground to see if we can get a result. I will post any updates in case any of you run into the same issue.

Thanks for the suggestions.

Cheers

Cameron
The administrator has disabled public write access.

504 Gateway timeouts 4 weeks 2 days ago #8383

  • sozzled
  • sozzled's Avatar
  • Offline
  • Moderator
  • I'm just a user, mate!
  • Posts: 116
  • Thank you received: 20
Did you try bumping up max_input_time?

Have you enabled the FTP layer in your Joomla Global Configuration settings? (If you did enable the FTP layer in Joomla, try disabling it; it's unnecessary if your folder/file ownership and permissions are correctly set.)
Read my blog and
Last Edit: 4 weeks 2 days ago by sozzled.
The administrator has disabled public write access.
The following user(s) said Thank You: Cameron S

504 Gateway timeouts 4 weeks 2 days ago #8384

  • Cameron S
  • Cameron S's Avatar
  • Offline
  • Junior Boarder
  • Posts: 38
  • Thank you received: 6
Hi sozzled,

You are a champion mate. Disabling the ftp layer fixed it. I had misread your first mention of it and all I had done was check that it was on, which it was. I'm not even sure why it got enabled, perhaps the reason may surface now but that is an easy workaround.

Both updates completed in seconds.

Thank you very much.

Cheers

Cameron
The administrator has disabled public write access.

504 Gateway timeouts 3 weeks 4 days ago #8387

  • mitchoor
  • mitchoor's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 6
  • Thank you received: 1
Good Morning Cameron,
We have the same issue with a local client we have a running through a content delivery network (CDN)
We have used both CloudFlare and Stackpath.

We have noted that we need to use a hosts file to bypass the CDN and connect directly with the server. Have a go loading this on your local PC and see if that resolves your issue.

support.rackspace.com/how-to/modify-your-hosts-file

Modify your hosts file
Modifying your hosts file enables you to override the DNS for a domain, on that particular machine. This is useful when you want to test your site without the test link, prior to going live with SSL; verify that an alias site works, prior to DNS changes; and for other DNS-related reasons. Modifying your hosts file causes your local machine to look directly at the IP address specified.
To modify the hosts file, you add two entries to the file that contains the IP address that you want the site to resolve to and the address. Adding the following two lines, for example, point www.domain.com and domain.com to our current PHP5-ITK (“Refreshed” PHP5) cluster:
64.49.219.194 www.domain.com
64.49.219.194 domain.com
The sections in this article provide instructions for locating and editing the hosts file on the following operating systems:
• Windows 10, Windows 8, Windows 7, and Windows Vista
• Windows NT, Windows 2000, and Windows XP
• Linux
• Mac OS X 10.0 through 10.1.5
• Mac OS X 10.6 through 10.12
After you add the domain information and save the file, your system begins resolving to the specified IP address. After testing is finished, remove these entries.
Windows
Windows 10, Windows 8, Windows 7, and Windows Vista use User Account Control (UAC), so Notepad must be run as Administrator.
For Windows 10 and 8
1. Press the Windows key.
2. Type Notepad in the search field.
3. In the search results, right-click Notepad and select Run as administrator.
4. From Notepad, open the following file: c:\Windows\System32\Drivers\etc\hosts
5. Make the necessary changes to the file.
6. Click File > Save to save your changes.

For Windows 7 and Vista
1. Click Start > All Programs > Accessories.
2. Right-click Notepad and select Run as administrator.
3. Click Continue on the Windows needs your permission UAC window.
4. When Notepad opens, click File > Open.
5. In the File name field, type C:\Windows\System32\Drivers\etc\hosts.
6. Click Open.
7. Make the necessary changes to the file.
8. Click File > Save to save your changes.

Windows NT, Windows 2000, and Windows XP
1. Click Start > All Programs > Accessories > Notepad.
2. Click File > Open.
3. In the File name field, type C:\Windows\System32\Drivers\etc\hosts.
4. Click Open.
5. Make the necessary changes to the file.
Click File > Save to save your changes.
I neither despise nor fear...
See you see you around...
The administrator has disabled public write access.
Time to create page: 0.059 seconds
Powered by Kunena Forum