Welcome, Guest
Username: Password: Remember me
Got a Joomla problem? Post as much detail about it as you can here to see if you can get a solution.

Help others in the community - post your Joomla tips and how-tos here.

TOPIC: Compatibility MySQL and 10.0.35-MariaDB

Compatibility MySQL and 10.0.35-MariaDB 1 week 5 hours ago #8456

  • magpie3
  • magpie3's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 1
I have a Joomla! website that I set up myself some years ago (without being a web developer). I have upgraded to Joomla 3.8.8. I asked my provider about the minimum server requirements following the upgrade. One is MySQL 5.5.3. The provider has 10.0.35-MariaDB on their server. They believe it is compatible with MySQL 5.5.3 but wish to have this confirmed. Can anyone confirm this?
The administrator has disabled public write access.

Compatibility MySQL and 10.0.35-MariaDB 1 week 4 hours ago #8457

  • tuum
  • tuum's Avatar
  • Offline
  • Moderator
  • Posts: 193
  • Thank you received: 60
Minimum MySQL requirements for Joomla 3.8.8 is MySQL 5.1, however 5.5.3 or greater is recommended.
downloads.joomla.org/technical-requirements

Joomla 4 will required MySQL 5.5.3 or greater
docs.joomla.org/Potential_backward_compa...y_issues_in_Joomla_4

So yes Joomla is compatible with what your hosting provider is currently offering.

regards

Tim
Follow me on twitter twitter.com/bfsurvey
The administrator has disabled public write access.

Compatibility MySQL and 10.0.35-MariaDB 1 week 4 hours ago #8458

  • manuman
  • manuman's Avatar
  • Offline
  • Moderator
  • Posts: 77
  • Thank you received: 19
This site is running on MariaDB :D
Co-Founder of Joomla!
CTO/Web Architect - Elastik Space elastik.space / Elastik Digital elastik.digital
The administrator has disabled public write access.

Compatibility MySQL and 10.0.35-MariaDB 1 week 4 hours ago #8459

  • Terry
  • Terry's Avatar
  • Offline
  • Fresh Boarder
  • Posts: 11
  • Thank you received: 3
Hi,

a quick Google and this item has the details for Compatibility between Maria and MySQL;

mariadb.com/kb/en/library/mariadb-vs-mysql-compatibility/

Specific to your question Maria 10.0 is compatible with MySQL 5.6 which is later than the minimum requirement so you should be okay.

Terry
Been working with Joomla for Fun and Work for 10 years.
The administrator has disabled public write access.
Time to create page: 0.042 seconds
Powered by Kunena Forum